Equisys technical notes

Technical guidance, explanations and fixes for our products

PRB: 'User not registered message' error from Email Gateway

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ZTN1402

ID: ZTN1402

This Zetafax technical note applies to:

  • Zetafax 7 and later using the Email Gateway

Symptom

The Email Gateway outputs a 'This user is not registered' message to the Zetafax server log.

Cause

The three main reasons why this error may occur are as follows:

  1. The user has a POP3 account configured alongside their Outlook profile.
  2. The user is attempting to add Email Gateway users using the Zetafax Configuration program while the Zetafax Server is running.
  3. It can also be due to auto enrolment where using the Zetafax SMTP Gateway

Resolution

  1. Remove the POP 3 account
  2. Close down the Zetafax Server before adding new Email Gateway users.
  3. If using the Zetafax SMTP server the email Gateway is not able to determine if the user specified in the FROM field in the *.TMP file matches valid Zetafax user account and therefore rejects the message.

To confirm this do the following:

  • Stop the Zetafax server and sent a fax from the mail client in question.
  • Open the resultant ENVx.TMP in the \Program Files\Zetafax SMTP Server\Data\OUT directory and note the email address in the FROM field between < < and > .
  • Go to the Zetafax Configuration program and lookup the Zetafax user. Make sure the email address matches the one in the FROM field. The syntax should follow the lines of:

smtp: Hal Hunter < hhunter@domain.com>

  • If not edit it to suit the FROM field.

If this does not resolve the problem check the following:

  1. Open the \SYSTEM\Z-DB\MAILUSER.DAT on the Zetafax server and remove the following lines if they exist:

*                    smtp:< *@domain.com>

*                    smtp:< *@*>

*                    smtp:< *@*.domain.com>

  1. Open the \ZFAX\SYSTEM\Z-DB\MAILLIST.INI on the Zetafax server and ensure you remove all the duplicate entries for each user that has Profile: YES.
  2. Confirm the email address matches the one in the FROM field and also confirm the email address matches the one in the FROM field in \ZFAX\SYSTEM\Z-DB\USERLIST.INI on the Zetafax server.
  3. Save all your changes and resubmit a fax from the mail client.

Status

This has been identified by Equisys as a problem with the software versions given above.

References

                      ZTN1418 HOWTO Configure the Zetafax Email Gateway for SMTP

Last update 02 November 2005 (LD/EB)

Date published 07 October 2004 (GR/SV)

Keywords < User not registered> < POP 3> < Auto enrolment>

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