Equisys technical notes

Technical guidance, explanations and fixes for our products

FIX: Zetadocs sends multiple copies of an email

Print

ZTN4534

This Zetadocs technical note applies to:

  • Zetadocs for NAV 10.0 to Zetadocs 11.1.2507
  • NAV 2017 and onwards

Symptom

Under certain circumstances, customers reported emails being sent multiple times. This can be observed in the Zetadocs activity logs, usually with a different user between the sends.

Cause

When a Zetadocs send process fails, Zetadocs has a retry mechanism in place to recover from the last action to perform and avoid sending multiple times.

A fault in this mechanism makes the full send process to be started again, resulting in multiple sends. This fault happens when the temporary pdf files are not found, so either when a second user runs the process, or when the temporary files have been cleaned.

Resolution

This fault was corrected in the cumulative update ZD 11.1.2508 available here.

Status

This behaviour was corrected in the update detailed above.

Last updated: 7th February 2020 (CR/NT) 

Equisys Logo, Document Management and Expense Management for Business Central
 

Replaced by script
Recent news

Understanding the profitability of projects is often a difficult and cumbersome process, especially if there is a lack of visibility around all the project costs. Getting that visibility of all ...

This article describes the new features and other improvements in the September 2021 update of the Zetadocs Expenses service. Zetadocs Expenses Release ...

North America
 
Equisys Inc
30000 Mill Creek Avenue
Suite 335
Alpharetta, GA 30022
USA
(770) 772 7201
Europe
 
Equisys Ltd
91 Southwark Bridge Road
London
SE1 0AX
United Kingdom
+44 (0)20 7203 4000
 

© Equisys Ltd
All rights reserved

© Equisys Ltd    All rights reserved    Contact    Privacy policy    Cookies