Equisys Technical Notes

Technical guidance, explanations and fixes for our products

PRB: Unable to open any page that contains the Zetadocs Document FactBox after importing language modules in NAV 2016

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ZTN4434

ID: ZTN4434

This Zetadocs technical note applies to:

  • Microsoft Dynamics NAV 2016
  • Version 7.1 of Zetadocs for NAV
  • Zetadocs Express

Symptom

The following error message is displayed when attempting to open any page that contains the Zetadocs Document FactBox after importing a language module in NAV 2016.

As a result the page that contains the Zetadocs Document FactBox cannot be opened.

Cause

This is a known issue with importing language modules in Microsoft Dynamics NAV 2016.

Resolution

After importing the language modules follow the steps below:

  1. Open the NAV Development Environment.
  2. Go to View -> Table Filter.
  3. In the Field, please type: Version List. And in the Filter type:
    1. Zetadocs Express users: ZDX*
    2. Zetadocs for NAV users: EQ*
  4. Press OK.
  5. Select all the Zetadocs Objects and compile them. Go to Tools -> Compile.
  6. Test it. Open again the page in the Web Client and in the Windows Client to verify that the error has disappeared.

References

·         HOWTO Import language modules from NAV 2013 R2 to NAV 2016

Last updated: 22nd October 2015 (JV) 

Keywords: NAV 2016 Metadata not synch for table with ID 9041209

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