Equisys technical notes

Technical guidance, explanations and fixes for our products

PRB: Zetadocs AP Automation matching does not match all lines when using Select All Rows

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ZTN4626

This Zetadocs technical note applies to:

  • Zetadocs Extension for Business Central version 3.0.24399

Symptom

While processing a document using Zetadocs Accounts Payable Automation Document Queue, when matching all purchase lines to a purchase order line using the 'Select all rows' option, only the first purchase line gets matched.

Cause

Zetadocs uses the currently selected Purchase Invoice lines when matching to a Purchase Order line to allow for efficient processing. However, when using the “Select all rows” functionality, Business Central does not currently pass to Zetadocs the necessary information to perform the matching of all the lines to the Purchase Order line selected.

Resolution

To avoid this issue, the multiple Purchase Invoice lines should be selected using the Shift and Ctrl key of your keyboard. This ensure that Zetadocs has the information required to perform the matching functionality as intended.

Status

This issue is caused by a third party component we will update this technote when a solution to this issue becomes available.

Last updated: 10th October 2025 (CR/NT) 

Keywords: Matching, Multiple lines, Select All Rows

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