Equisys technical notes

Technical guidance, explanations and fixes for our products

PRB: Brooktrout E1 solution does not answer inbound calls.

Print

ZTN1072

ID: ZTN1072

This Zetafax technical note applies to:

  • Zetafax 6 and later

Symptom

Brooktrout device reports 'Unable to connect to remote fax (4, 34)' when dialling itself on a free channel or remote sender will receive an engaged tone.

Cause

The default BCHANMAP.CFG file is configured such that the Brooktrout drivers listen for incoming PRI calls starting with PRI bearer channel 1. If that channel is busy they try channel 2 then channel 3, etc. Some service providers configure their systems so that calls come in on bearer channel 31, and then channel 30 etc. This means that if you have all 30 PRI channels live, but have fewer than 30 Brooktrout channels connected to the system, incoming calls will be rejected.

Resolution

The solution to this problem is to edit BCHANMAP.CFG so that the Brooktrout boards map to the top bearer channels.

This can be done by using a suitable text editor to edit \bfax\server\BCHANMAP.CFG, (where 'bfax' is the name of the directory where the Brooktrout ECC files are installed.):

You need to edit the second column of numbers in BCHANMAP.CFG so that instead of counting up from channel 1 it counts down from channel 31 (or one less than the number of lines you bought if you are using fractional PRI). For example, if you have eight channels attached to port B then need to change from:

# Created by Zetafax.

# Revision: A

# BoardType: E1

#

# port channel mvip_stream mvip_timeslot

#

1 1 6 0

1 2 6 1

1 3 6 2

1 4 6 3

1 5 6 4

1 6 6 5

1 7 6 6

1 8 6 7

To:

# Created by Zetafax.

# Revision: A

# BoardType: E1

#

# port channel mvip_stream mvip_timeslot

#

1 31 6 0

1 30 6 1

1 29 6 2

1 28 6 3

1 27 6 4

1 26 6 5

1 25 6 6

1 24 6 7

NOTE: Bearer channels 0 and 16 are not used for calls.

Save the file, stop the Zetafax server and the BTNA service and then restart the Zetafax server. This will ensure that the BTNA Service is restarted with the new parameters.

Status

This has been identified by Equisys as a problem with the software versions given above.

Last updated: 22 June 2000 (GC/GW)

Equisys Logo, Document Management and Expense Management for Business Central
 

Replaced by script
Recent news

The sudden rush towards remote working practices in 2020 led many organizations to implement changes to upgrade their document capture processes on Microsoft Dynamics 365 Business Central or ...

Company credit cards are often seen as the most convenient way to incur travel & entertainment expenses, however it can be a very different story when it comes to the administration of these ...

North America
 
Equisys Inc
30000 Mill Creek Avenue
Suite 335
Alpharetta, GA 30022
USA
(770) 772 7201
Europe
 
Equisys Ltd
91 Southwark Bridge Road
London
SE1 0AX
United Kingdom
+44 (0)20 7203 4000
 

© Equisys Ltd
All rights reserved

© Equisys Ltd    All rights reserved    Contact    Privacy policy    Cookies