Equisys technical notes

Technical guidance, explanations and fixes for our products

FIX: Incoming faxes are deleted when email server is down.

Print

ZTN1274

ID: ZTN1274

This Zetafax technical note applies to:

  • Zetafax version 7.5.0.65 and earlier

Symptom

If a Zetafax server is configured to forward received faxes to an email user using the email gateway, all inbound messages are deleted if mail the server is unavailable.

Cause

With older versions of Zetafax the email gateway deletes the incoming messages in SERVER\MAILOUT if the email sever is unavailable (e.g. the Exchange server system is down).

Resolution

If you have Zetafax version 7.5.0.65 or earlier you need to update Zetafax to the latest version. For more information please refer to Equisys website.

http://www.equisys.com/updates

Note: Users who have version 7 or earlier will need to purchase an upgrade. For more information please contact Equisys or the Zetafax distributor for your country.

If you have a later version of Zetafax it will not delete incoming messages if the mail server is unavailable. However it will rename any messages which it has cannot forward to the email server to the recipient of an incoming message in SERVER\MAILOUT, the gateway now renames the file from MAILxxx.SIN to MAILxxx.ERR. Next time it succeeds in connecting to that mail server it renames all the ".ERR" files in SERVER\MAILOUT from MAILxxx.ERR to MAILxxx.SIN and starts processing them.

Status

This behaviour was corrected in Zetafax version 7.5 (including update) or later.

Last updated: 04 November 2005 (RM/EB)

First Published:  14th May 2003 (LD/SV)

Equisys Logo, Document Management and Expense Management for Business Central
 

Replaced by script