Equisys Technical Notes

Technical guidance, explanations and fixes for our products

PRB:Zetadocs for NAV Report Fails Periodically

Print

ZTN4004

ID: ZTN4004

This Zetadocs technical note applies to:

  • Zetadocs for NAV 1.1 running on:
    • Microsoft Dynamics NAV 4.0 SP2 or lower.
    • Microsoft Dynamics NAV 4.0 SP3 Client with Build < 25143

Symptom

When running a report that has been modified to work with Zetadocs for NAV you see the following error message:

After checking the Zetadocs for NAV log file you see the following log description:

            Error-C9009960 - IsToBeSkipped: Failed to find related send result. ERROR < RecordID>

 

Where < RecordID> will be a table name and its keys for the current record.

 

Cause

There is a bug in Microsoft Dynamics NAV 4.0 SP2 or lower which causes a failure to find records in a table when the primary key varies between numeric and alpha numeric values.

Resolution

  1. Upgrade to using the Microsoft Dynamics NAV 4.0 SP3 Client – Build 25143 or later.


  2. OR

  3. Contact Equisys Technical Support at support@equisys.com.

Status

This has been identified by Equisys as a problem with the software versions given above.

Last updated: 17 April 2008 (BM/DH)

EquisysLogo

Recent news

As part of our drive towards making the software simpler to use, Zetadocs Expenses now supports single sign-on using Microsoft work or school accounts. This makes it easier for Office 365 ...

This article describes the new features and other improvements in the August 2019 release of the Zetadocs Expenses service. Zetadocs Expenses ...