Equisys Technical Notes

Technical guidance, explanations and fixes for our products

HOWTO: Automate faxing from Maximizer®

Print

ZTN1212

ID: ZTN1212

This Zetafax technical note applies to:

  • Zetafax 7.5 and above
  • Maximizer 7 & 8
  • Maximizer Enterprise 7 & 8

Summary

Maximizer offers support for automated faxing from Microsoft Fax as standard. This support is now extended to include Zetafax. This document will explain the following:

  • How to create a fax template within Maximizer.
  • How to send a fax from within Maximizer.

More information

How to create a fax template within Maximizer.

Documents faxed from Maximizer are a combination of two elements, the document template and the contact data. The document template must contain commands that determine how Zetafax should treat each fax job. Referred to as Embedded Addressing commands, these specify the destination number, whether the fax is to multiple recipients and so on. The Zetafax server removes the commands from the document before it is faxed.

The following example modifies an existing template and uses basic commands allowing automated faxing to single and multiple recipients.

  1. Launch Maximizer Word Processor by choosing Write a document on the Actions menu, the 'Create New Document' dialog box appears.
  2. If the Maximizer Word Processor window is already open, select New from the File menu.
  3. Type a name for your document in the Document Details group box. (For example Zetafax Cover Page)

  1. In the 'Create As This Type of File' group box, select the Template checkbox.
  2. In the 'Use This Template as the Basis for New File' list box, select '*Fax Form'.
  3. Click OK. The template will be launched within the Maximizer Word Processor.
  4. At the very top of the document insert the following:

%%[TO:{Fax_Number?},{First_Name?} {Last_Name?},{Company?}]

Note: Commas are required to separate fax, name and company.

where the {Fax_Number?} field is the Maximizer fax field that corresponds to the fax number of the recipient. To insert this field, from the Maximizer Word Processor menu select Tools | Merge Field and select 'Fax Number' from the list. Without this it would be necessary to manually enter the fax number for each recipient.

  1. To fully automate the process of faxing a coversheet, the %%[SEND] command should be inserted at the end of the document. This will ensure the Template is faxed with no user intervention. It must be noted that this is an optional command that does not have to be inserted; however it is highly recommended to do so.
  2. Once the Embedded Addressing commands have been inserted, save the document and exit the Maximizer Word Processor.
  3. Zetafax Embedded Addressing offers much greater functionality than described above. Of particular interest is the ability to insert signatures in the template and to delay sending of the fax in order to take advantage of reduced call costs after hours. These additional abilities are only available with the purchase of the Zetafax API Toolkit. Please contact either your local Equisys Solution Partner or Equisys for further information.

How to send a fax from within Maximizer

There are a number of ways to send a fax from within Maximizer. We have described two below.

Faxing a document

  1. In a controlling window, select an entry to which you want to send the fax.
  2. In the 'Documents' window, double-click on a blank field, or choose Add Document form the Edit menu.
  3. The 'Add Document' dialog box appears.

  1. From the 'Use this Template as the basis for new file' select the fax template you have created previously (in this case Zetafax Cover Page) and click 'OK'.
  2. This will launch the Zetafax Cover Page within the Maximizer Word Processor.
  3. Type your fax.
  4. When you are finished, print the document to the Zetafax Printer. If the Coversheet had the %%[SEND] command embedded, the fax will be automatically sent. If the Coversheet did not include the %%[SEND] command, the Zetafax addressing dialogue box will pop up - allowing the user to manually send the coversheet in question.

NOTE: In this example we are assuming that the default coversheet on the Zetafax client is set to 'None'.

  1. In the Print dialogue box you have the ability to create a subject for the document you are faxing by typing in the 'Log this message in the current entry's Notes' field.
  2. Click 'OK' to fax the document.
  3. Close the Maximizer Word Processor and save the document you have faxed.

Faxing Mail Merge documents Maximizer 7

  1. In a controlling window, select the entries you want to include in a mail merge.
  2. In the Maximizer Word Processor window, select 'Open' from the 'File' menu.
  3.   In the 'Open Template' dialogue box, select a template you have created previously.
  4. Click the 'Open' button. The Maximizer Word Processor opens the document.
  5. Select Merge | to Printer from the File menu. The Merge Options dialogue box appears.

  1. Adjust the Merge Template with the Selected and Print Option group boxes.
  2. Click 'OK'.
  3. Click 'Print' to fax the current document and move to the next Address book entry or 'Print all' to fax all of the documents for the mail merge.
  4. Select the Zetafax Printer from the Print dialogue box. If the document had the %%[SEND] command embedded, the fax will be automatically sent. If document did not include the %%[SEND] command, the Zetafax addressing dialogue box will pop up - allowing the user to manually send the coversheet in question.
  5. On the Print dialogue box you have the ability to create a subject for the document you are faxing by typing in the 'Log this message in the current entry's Notes' field.
  6. Click 'OK' to fax the document.
  7. Close the Maximizer Word Processor and save the document you have faxed.

Faxing Mail Merge documents in Maximizer 8

  1. From the Address Book  window, select the entries you want to include in a mail merge.
  2. In the Maximizer Word Processor window, select 'Open' from the 'File' menu.
  3. In the 'Open Template' dialogue box, select a template you have created previously.
  4. Click the 'Open' button. The Maximizer Word Processor opens the document.
  5. Select Merge | to Printer from the File menu. The Merge Options dialogue box appears.

  1. Adjust the Merge Template to select 'Address Book window entries' and 'All Selected entries'
  2. Click 'OK'
  3. Click 'Print' to fax the current document and move to the next Address book window entry or 'Print all' to fax all of the documents for the mail merge.
  4. Select the Zetafax Printer from the Print dialogue box. If the document had the %%[SEND] command embedded, the fax will be automatically sent. If document did not include the %%[SEND] command, the Zetafax addressing dialogue box will pop up - allowing the user to manually send the coversheet in question.
  5. On the Print dialogue box you have the ability to create a subject for the document you are faxing by typing in the 'Log this message in the current entry's Notes' field.
  6. Click 'OK' to fax the document.
  7. Close the Maximizer Word Processor and save the document you have faxed.

References

Full instructions on the use of all of these features are available in the online help. Also see the following technical note for reference:

ZTN1011 HOWTO: Using Embedded addressing

Last updated: 31 Aug. 2005 (MS/EB/LD)

First Published: 26 July 2002 (RS/GC)

EquisysLogo

Recent news

This article describes the new features and other improvements in the August 2019 release of the Zetadocs Expenses service. Zetadocs Expenses ...

This article describes the new features and other improvements in the latest release of Zetafax. This improves support for using Fax over IP (FoIP) with SIP trunks and public SIP fax services, ...