Equisys technical notes

Technical guidance, explanations and fixes for our products

PRB: Zetadocs Error 9999 when sending with an SMTP password containing semicolons

Print

ZTN4551

This Zetadocs technical note applies to:

  • Zetadocs Delivery and Capture Extension for Business Central 1.0 and above

Symptom

When doing a Zetadocs Send, and error message "Zetadocs has encountered an error when executing the Zetadocs Web Api request 9999" is shown in the outbox and the message is not delivered.

Cause

This is caused by the way the SMTP Server settings are held before using them to send the email, the semicolon in the password causes internal issues when packaging up communications to the SMTP server with current versions of the software.

Resolution

A workaround is currently possible by changing the password for the SMTP Server to avoid use of semicolons, and update the Zetadocs Delivery Settings page, then Zetadocs Send should work.

Status

Equisys is aware of this issue and will update this technical note when a solution has been found.

Last updated: 20th November 2020  (MP/NT) 

Keywords: Zetadocs Delivery, SMTP Server

Equisys Logo, Document Management and Expense Management for Business Central
 

Replaced by script

Seeing the wood for the trees

Given how much the average employee claims in expenses every year, it is vital for companies to understand and manage their spending on expenses. Zetadocs Expenses offers you the ability to do this.