Equisys technical notes

Technical guidance, explanations and fixes for our products

PRB: Report layout cannot be viewed in the RoleTailored client when executing Save and Send

Print

ZTN4143

ID: ZTN4143

This Zetadocs technical note applies to:

  • Version 5.0 of Zetadocs Express
  • Microsoft Dynamics Navision 2009 R2

Symptom

On attempting to perform a Save and Send from the RoleTailored client an error message is displayed saying that the “the layout of this report has not been transformed to be viewed in the RoleTailored client” with a report ID number.  The error message is displayed below:

The Save and Send will not have been performed, click OK to continue and use the steps below to resolve this issue.

Cause

Effectively the Save and Send functionality executes a specific Navision report depending on the record type used. This issue occurs if the corresponding report hasn’t been configured or modified to be used within the RoleTailored client.

Resolution

This issue can be resolved by creating a suggested layout for the corresponding report:

  1. Open the Navision Classic Client.
  2. Open the Object Designer (Shift + F12 or Tools > Object Designer).
  3. View all reports.
  4. Select and design the corresponding report number (ID 205 for this example).
  5. Go to Tools > Create Layout Suggestion.
    This will open the Visual Studio Report Editor. Click OK if any error message is displayed.
  6. Close the editor and save the report XSD file.
  7. You will be prompted to reload the report as the layout changed. Click Yes.
  8. Close the report and compile it.

Status

This has been identified by Equisys as a configuration problem between the Zetadocs Express and Microsoft Dynamics Navision versions given above

Last updated: 29/09/2011 (SD/MW)

Equisys Logo, Document Management and Expense Management for Business Central
 

Replaced by script
Recent news

The sudden rush towards remote working practices in 2020 led many organizations to implement changes to upgrade their document capture processes on Microsoft Dynamics 365 Business Central or ...

Company credit cards are often seen as the most convenient way to incur travel & entertainment expenses, however it can be a very different story when it comes to the administration of these ...

North America
 
Equisys Inc
30000 Mill Creek Avenue
Suite 335
Alpharetta, GA 30022
USA
(770) 772 7201
Europe
 
Equisys Ltd
91 Southwark Bridge Road
London
SE1 0AX
United Kingdom
+44 (0)20 7203 4000
 

© Equisys Ltd
All rights reserved

© Equisys Ltd    All rights reserved    Contact    Privacy policy    Cookies