Equisys technical notes

Technical guidance, explanations and fixes for our products

PRB: Email attachment images are converted in Black & White on Zetadocs Server

Print

ZTN4578

This Zetadocs technical note applies to:

  • Zetadocs Server 4.1.25261

Symptom

When processing emails with embedded images with Zetadocs Server, the images are converted into Black & White when converting the email to PDF.

Cause

A limitation with a 3rd party dll running OCR over the document to be converted (for barcode reading) is converting the image to black and white.

Resolution

If the images are not needed for batch splitting or barcode reading then the OCR setting for either that Queue or for the system as a whole should be switched off.

To switch off OCR for a specific queue, add or change entries in the queue settings to in the config.xml file for Zetadocs Server as follows (changes/additions to the DocsQ section in bold):

<DocsQ Description="Queuename" Location="\\server\queuelocation\">
     <EnableOcrForQueue>false</EnableOcrForQueue>
     <BatchScanSplitType>Off</BatchScanSplitType>

</DocsQ>

If barcode reading isn't required at all for any queues then the global EnableOcr setting at the bottom of the config file can be set to false:

<EnableOcr>false</EnableOcr>

Status

This issue is caused by a third party component we will update this technote when a solution to this issue becomes available.

Last updated: 2nd June 2026 (YE/NT) 

Keywords: Zetadocs Server, Convert

Equisys Logo, Document Management and Expense Management for Business Central
 

Replaced by script